请选择 进入手机版 | 继续访问电脑版

121

积分

0

精华

2 小时

在线时间

应届白菜

Rank: 1

发表于 2019-8-13 22:09:09 109 浏览 14 回复

[P系列无人机] Qt编辑QGC运行时出现错误

1阿木币
用QT编辑QGC,从网站上用Git下载的代码,安装的教程带的QT和visual第一次打开运行后出现这个错误在项目里面构建和运行里面有红叹号 求教怎么解决
附件: 您需要 登录 才可以下载或查看,没有帐号?立即注册

最佳答案

查看完整内容

你的报错的确就是提示没有更新这个子模块

扫一扫浏览分享
回复

使用道具 举报

176

积分

0

精华

27 小时

在线时间

应届白菜

Rank: 1

发表于 2019-8-13 22:09:10
你的报错的确就是提示没有更新这个子模块

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复

使用道具 举报

322

积分

0

精华

42 小时

在线时间

老司机

Rank: 2

发表于 2019-8-14 08:42:30
点进去那个感叹号,看看说了些啥。
回复

使用道具 举报

176

积分

0

精华

27 小时

在线时间

应届白菜

Rank: 1

发表于 2019-8-14 10:09:15
下载下来的源码需要更新子模块。
进入到下载的qgc代码中 cd qgroundcontrol/
然后更新子模块 git submoudle update --init --recursive
这样应该会解决你上图的问题。
但是要编译qgc的源码,要知道qgc的版本号与Qt版本号要一一对应。我常用的是Qt5.11.0+qgc-v3.3.2
回复

使用道具 举报

176

积分

0

精华

27 小时

在线时间

应届白菜

Rank: 1

发表于 2019-8-14 10:11:16
这是win下面的,我刚说的是Ubuntu下的。不确定能否解决,但错误提示就是没有更新子模块
回复

使用道具 举报

121

积分

0

精华

2 小时

在线时间

应届白菜

Rank: 1

 楼主| 发表于 2019-8-15 11:07:27
@我们课老师
回复

使用道具 举报

121

积分

0

精华

2 小时

在线时间

应届白菜

Rank: 1

 楼主| 发表于 2019-8-15 11:15:34
@我们课老师

用QT编辑QGC,从网站上用Git下载的代码,安装的教程带的QT和visual  第一次打开运行后出现这个错误  在项目里面构建和运行里面有红叹号 求教怎么解决
我来回答
回复

使用道具 举报

1187

积分

0

精华

145 小时

在线时间

版主

Rank: 7Rank: 7Rank: 7

发表于 2019-8-15 14:05:37
WANGJIYUAN 发表于 2019-8-15 11:15
@我们课老师

用QT编辑QGC,从网站上用Git下载的代码,安装的教程带的QT和visual  第一次打开运行后出现这 ...

有人上面给你回答了哈,可以点击回复来沟通。
回复

使用道具 举报

121

积分

0

精华

2 小时

在线时间

应届白菜

Rank: 1

 楼主| 发表于 2019-8-15 16:01:58
eason 发表于 2019-8-14 10:09
下载下来的源码需要更新子模块。
进入到下载的qgc代码中 cd qgroundcontrol/
然后更新子模块 git submoudle ...

我用Git 输入了git submoudle update ; git submoudle init ; git submoudle recursive 这些都输了  还是出现同样的错误  好像没管用
回复

使用道具 举报

121

积分

0

精华

2 小时

在线时间

应届白菜

Rank: 1

 楼主| 发表于 2019-8-15 16:03:09
@maxiou 可不可以远程桌面帮我看一下啊
回复

使用道具 举报

下一页 »
12下一页
返回列表
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

官方淘宝店

 阿木社区

微信公众号

AMOV_UAV

扫一扫,快速加入

群号652692981

快速回复 返回顶部 返回列表